Writing a GUI to TWS in C# part 3

Discussion in 'Trading' started by Fredrik99, May 12, 2006.

  1. So far, so good! I have written a little app in C#,that receives streaming data from IB.
    I have also converted it into a DLL that I am calling from a GUI. Later on I will skip the GUI and incorporate the DLL in a larger trading system, that I am writing with a group of friends.
    Thanks a lot for the valuable hints I got on this forum.

    Now I am curious....how about the little Java GUI that asks me if I want to accept the incoming connection...can I get rid of it and just write some code that will automaticaly accept the connection?

    Thanks in advance

  2. Look at the trusted connections option under the settings. It lets you specify trusted IP addresses/hostnames that will not give you the prompt. For example "" and "localhost" are good ones to populate.

  3. Thanks. The settings you talk about.. are they windows settings?
  4. Got a screen shot of the GUI? Just curious to see how it came out, haven't checked part 1 or 2.
  5. Right now it looks like this, but its sort of besides the point. I wrote the GUI just to be able to test a DLL . the DLL contains all code that directly communicates with the TWS. I will drop the GUI later, when it is time to hook up the DLL to the main program.
  6. SlideShowBob,
    I found those settings in the TWS. Thank you!
    Unfortunately the java message box comes anyway.
    it says:
    "Accept incoming connection attempt?"

    I would like to automate this procedure, since there will be noone around to handle it( except the system)

  7. lastick


    If you set it properly like said by SSB, the msg box would not appear...Check your local adress.
  8. Maybe I make some mistake, I don´t know. Anyway my local ip is the Configure menu in IB Trader Working Station, I go to "API" and select trusted Ip addresses and enter I klick apply and OK. Then I turn to my own C#-app and klick connect. And the confirmation prompt keeps coming.
  9. lastick


    I don't think the value you entered is your local host adress. try
  10., is the ip-adress on this machine, as reported by the ipconfig command (executed in the command prompt)
    I tried as well, but it does not change anything.
    #10     May 15, 2006