Where is my ddedll.dll?

Discussion in 'Trading Software' started by Fte_Fce, Sep 2, 2009.

  1. Fte_Fce


    Hi all,

    I have recently downloaded the API software from IB (installAX_962) and receveived the following message :

    "the ddedll.dll file required for Excel integration is either missing or out of date.
    The dll can be refreshed with the most up-to-date version can by downloading and installing the API Software from our web site"

    I have already done all the up-date I can.

    Vista and Excel 07

    Many thanks for your help

  2. TraDaToR


    Same thing here. Windows 7 and Excel 2006. Does anybody know how to fix it?
  3. spacewiz


    I had the same issue, just figured it out.

    Seems that this problem is affecting only users of 64-bit Windows machines.

    You need to make sure your TWS is running ona 32-bit version of Java, instead of the 64-bit that is often pre-installed on Windows 64-bit.


    1. Download a 32-bit version of Java Development Kit (JDK) from http://java.sun.com/javase/downloads/widget/jdk6.jsp.

    IMPORTANT: select "Windows" instead of "Windows x64"

    2. Note the directory where 32-bit JDK is installed.
    For example I installed the 32-bit version on my computer under:
    C:\Program Files (x86)\Java\jdk1.6.0_16

    Your version will be different, I've had mine installed for a while...

    3. After installing 32-bit Java : right-click on TWS icon, and select "Properties"

    4. In the shortcut's Properties window, in "Target" replace path to javaw.exe to point to the 32-bit Java directory.

    For example on my computer I had to change first part of the value
    from: C:\WINDOWS\system32\javaw.exe

    to: "C:\Program Files (x86)\Java\jdk1.6.0_16\bin\javaw.exe"

    (you will need the double quotes if you have spaces in the path)

    My full value of Target text box is now:
    "C:\Program Files (x86)\Java\jdk1.6.0_16\bin\javaw.exe" -cp jts.jar;hsqldb.jar;jcommon-1.0.12.jar;jfreechart-1.0.9.jar;jhall.jar;other.jar;rss.jar -Dsun.java2d.noddraw=true -Xmx1024M jclient/LoginFrame C:\Programs\Jts

    SIDE NOTE: Notice - I bumped up amount of memory allocated to TWS from original 512MB to 1GB - this will let TWS run faster , do this only if you have plenty of memory - at least 4GB.
    Change "-Xmx512M" to "-Xmx1024M"

    Hope this helps.
  4. TraDaToR


    Thanks a lot Spacewiz. Much appreciated.:)
  5. MGoTrader


    Two great tips and moocho time saved!!!

    I can't thank you enough.

    See attached...
  6. ozonewave


    It is not necessary to downgrade to 32 bit Java. The problem is just that the default setting on TWS looks for 32 bit Java, but you should just change the Target text box (preferences) to look for the pre-installed 64 bit Java.

    You just change:


    I think it's a good idea to increase the memory to 1024 as you indicated.

    The full value of the Target text box is now:
    C:\Windows\SysWOW64\javaw.exe -cp jts.jar;hsqldb.jar;jcommon-1.0.12.jar;jfreechart-1.0.9.jar;jhall.jar;other.jar;rss.jar -Dsun.java2d.noddraw=true -Xmx1024M jclient/LoginFrame C:\Jts
  7. timoth22


    i was having the same problems using 64bit Win7, but the above solutions didn't work. I have no idea why, but the following did work.

    • Uninstalled all java.
    • Installed Java%20Runtime%20Environment%2016022; supposedly a 32 bit version, but it was installed into windows/sysWOW64bit/ folder
    • Copied 3 jav*.* files from sysWOW64 to system32 folder, and I could use IB API TwsDde Excel spreadsheet after a new install of TWS and the API software
  8. berserk


  9. dhride


    The Ram tip is of great value to me. thanks
  10. dhride


    I have tried to increase the memory to 2048M and 4096M and when launching the program I get an error that the java virtual machine could not be created.
    I assume that it has to do with the java memory allowance size rather than with TWS.
    Any idea on how could I increase the java virtual machine memory as well?
    #10     Nov 30, 2011