What is Oldest TWS I can run? And WHERE to get?

Discussion in 'Retail Brokers' started by d9d, Aug 14, 2007.

  1. d9d


    I was away from trading since the end of 2005; and am now back home and picking things up again.

    My TWS icon is labeled 851, but I've noticed that error logs say it's Build 854.4, Nov 29, 2005.

    It used to work flawlessly; but when I tried to start it today, I could not get past the little login window.

    After entry of user/pw, it popped up a 2nd little window telling me there isn't a disk in drive F: (which is the CD on this laptop).

    It never ever did that before.

    I hit 'continue', same error popped up, hit continue again, and the login window went away. Never started the TWS.

    Tried the whole process a couple times, but never got further. Tried it with a CD in the drive, and it didn't pop up that extra error, but it did still quit without getting past the login window.

    It never puts up any sort of useful info about what's wrong.

    Looking in the log.Mon.txt file, I can see mention of two different things:

    - most attempts end with a line in the log saying: Login failed - Invalid username or password (but I tried the user/pw on the website and it still works fine)

    - a couple of the attempts instead show this in the log file:
    "The TWS build you are currently running is no longer supported."

    So, my questions are:

    - Is it true that 851 or 854 won't run, i.e. isn't supported any more?

    - If not true, then does anyone have any idea why it'd be looking on the CD drive? (it never did that back when I used it in 2005/early 2006)

    - If my version truly won't run any more, then what is the OLDEST and simplest, most stable, TWS that -will- still work?

    - And where do I get it?

    If someone has old versions that they could put up on an FTP for a day, please PM me. I'm on dialup, so an email with a 10mb attachment doesn't work real well...lol...

    ps; I am especially concerned about getting an old enough version to not require any 'security' device.

    thanks much!
  2. AFAIK this won't work. You must use the device and this will require a newer TWS.

    Also, you can't get to account management without it anyway, or at least you need the little Key "lookup" chart (smaller accounts).

    It just takes a couple days to get the device. I've been using it for several years with no problems.
  3. Bob111


    i have them all,let me know,if you need TWS below kiwi's 872. i far as i remember that message-lowest working should be 870(or 871)
  4. d9d


    kiwi, thanks much for the link. Is that an 'upgrade' or a full-install file ?

    Bob111, thanks very much for the files offer...I'll PM or post again here if I need one of them.

    OptionAttack, fwiw, I was able to access acct. mgmt on the website without any trouble yesterday; with only my username/pw...no security device.

    Also, before posting last night, I had read every thread I could find here on the security-device; and it seemed certain that one could opt out of it.

    Someone had even posted the text of the waiver.

    I searched the IB website yesterday, and could not find that waiver....but I -did- find their webpage describing the STP program; and it says the device-requirement isn't turned on until you opt IN to the STP setup.

    In any case, as I mentioned, I was able to log into the acct mgmt web page OK without it.

    If anyone from IB is reading this, and can comment, I'd be grateful if you could verify whether or not I should be able to load and run TWS without the device. Again, the situation is that I have not accessed my account or even run TWS in over a year; and my acct is below 100K.

    thanks very much to all who've replied