TWS under RH-64 Linux

Discussion in 'Trading Software' started by nitro, Mar 8, 2005.

  1. nitro


    Does anyone know if IBs TWS will run under Linux?

    I just downloaded the jar files (weird tho, looks like the mac and unix file is the same) and when I tried to run it, I got an exception:

    "GtkMain": java.lang.UnsatisfiedLinkError: gktInit

  2. Yes, I have run it under Fedora Core 3. As it's in Java, the jar file should be the same. You might want to install gtk devel package to see if it goes away.
  3. def

    def Interactive Brokers

    I'm running one at work with Red Hat (I think enterprise version) and it runs extremely well. I can't offer any specifics with your case but you can try sending a mail to who may be able to help.
  4. cable


    It looks like it's trying to initialize gtk and can't find it. Do you have Gnome Toolkit properly installed? Is java properly installed? Not that this post is much overt help, but in the past I have had a few ugly little linux problems, and it's usually that I've compiled something into the wrong directory or don't have it installed properly. Specifically, I was trying to install GStalker on Linux, and it WAS my GTK+ that wasn't working. I had compiled it into the wrong directory. The install file told me one thing, and the app required another directory. I unhappily don't remember how I fixed it, but it was a one-line fix that I found through Google and hours of stress. But after that, everything was peachy-keen. Perhaps try to install the GStalker app and see if that one works -- it's also dependent on GTK+.
  5. nitro


    Thanks, I will give it a try.

  6. nitro


    Thanks Dave, if I can't figure it out I will send them an email.

  7. nitro


    Thanks for the tips.

    All the software was installed for me. I will research more carefully if GTK+ is installed.

  8. def

    def Interactive Brokers

    if you don't have luck send me an e-mail and I'll figure out exactly what's installed on my system to figure out where your problem lies. I'd rate myself pretty knowledgable on Unix but I've got a long way to go on Linux though.
  9. I haven't tried AMD 64 Linux yet, so I'm just shooting in the dark, but here's a couple of ideas -

    Are you running 32 bit or 64 bit jvm ? If 32 bit then even though gnome/gtk 64 bit libs may be installed, 32 bit may not be or they are not being loaded. And visa versa.

    Try locating all gtk libs on the system -

    find / -name "*gtk*so*" -print 2>/dev/null

    You can force any binary to amend it's search path for shared libs with the LD_LIBRARY_PATH environment variable eg

    export LD_LIBRARY_PATH=/usr/mylibs:$LD_LIBRARY_PATH

    will cause /usr/mylibs to be searched for shared libraries first before anywhere else.
  10. nitro



    That is a good try. I get the same error:

    [idf@sync-dell IBJts]$ java -cp jts.jar:jcommon-0.9.0.jar:jfreechart-0.9.15.jar jclient.LoginFrame .

    Exception in thread "GtkMain" java.lang.UnsatisfiedLinkError: gtkInit
    at _Jv_LookupJNIMethod (/usr/lib64/
    at, void, ffi_raw, void) (/usr/lib64/
    at (Unknown Source)
    at (/usr/lib64/
    at _Jv_ThreadRun(java.lang.Thread) (/usr/lib64/
    at GC_start_routine (/usr/lib64/
    at __clone (/lib64/tls/

    [idf@sync-dell IBJts]$


    #10     Mar 10, 2005