TWS chart bug

Discussion in 'Interactive Brokers' started by harami, Aug 22, 2019.

  1. harami

    harami

    Does anyone else have this issue? It's driving me nuts. Zooming in and out of a chart causes the bars to overlap each other if the chart includes extended hours trading. The only way to fix it (temporarily) is to switch the symbol or timeframe of the chart and then switch it back again. I'm using build 974.4o, but the same thing happens on other versions too.


    twsbug.jpg
     
  2. Don't use tws for anything except the actual execution. Sometimes the research links are helpful though
     
  3. There should be an icon in the toolbar (you may have to put it there yourself) that adjusts the width of the candles. Sometimes I have to use it. No biggie.
     
    tommcginnis and isc1746 like this.
  4. isc1746

    isc1746

    Should have an Icon on the Chart for "More Icons". Select the Icons you want to customize the chart and then save as a template. Lots of flexibility.
     
    tommcginnis likes this.
  5. All you guys are avoiding the point that this glitch is something that shouldn't happen. I get this sometimes as well. Not sure what causes it. Happens even when candle widths are automatic.

    I also have issues with intraday vwap just not being accurate. And even different between different time frame charts on the same ticker
     
    harami likes this.
  6. harami

    harami

    That doesn't work. It's essentially the same thing as zooming in and out with the mouse wheel.
     
  7. CharlesS

    CharlesS

    More workarounds:

    If using Mosaic, select a different tab, and then re-select the one that has the problem.

    If not using Mosaic, select a different TWS window, then re-select the one that has the problem.

    These sometimes re-enable control of candle width.
     
    Last edited: Aug 22, 2019