Slowness Really Hurts Us

Discussion in 'Hardware' started by dedicated1, Sep 20, 2003.

  1. My quotes are soo slow!! My profitability is greatly comprimised due to this. I have a P4 1.8Ghtz 1gig memory 1- 64mb dualhead video card running 2 monitors and 1 onboard 64mb intel video driving my 3rd monitor. I connect via a T3 line and my throughput speed is consistently fast. Problem is when I put up 1 or 2 highly liquid stocks on my L2's the CPU gets maxed out and the quotes start to stutter step rather than a continuous flow as the quotes and prints come in. Please share any insights you may have. Thanks so much.
  2. What O/S are you using? My system is a bit slower than yours and has two video cards (1 dual-head, 1 single) for triple screens and I still don't experience any speed problems. I'm running Win XP Pro.

  3. Dude, unlike in penal matters, it's not how big your hardware is, it's what you do with it! You sound like the kind of person who would use Windows XP, so I'll customize my answer for that case:

    1. Turn off all unnecessary services. There are several sites on the internet that attemt to walk you through the process. One of them is if someone else knows a better one, please post.

    2. defragment your hard drive Start -> Programs -> Accessories -> System Tools -> Disk Defragmenter

    3. When your trading and charting applications are running, press Ctrl+Shift+Esc. This should bring up the task manager. Find all the processes that you need to run really fast (they will probably be the ones that are already using up most of the CPU) and change their priorities to "High" or "Above Normal". You will have to experiment with the individual settings to find the optimal set. This procedure has to be repeated every time after you have started your trading and charting applications. There is probably a way to make the settings permanent, i.e. assign a default priority other than "Normal" to certain programs or processes, but it also wouldn't surprise me if this were impossible. After all, this is Microsoft Windows we are talking about. If anyone knows any details, please post.
  4. I am currently running WinXP pro, I have updates the o/s, defragmented the drive, i ahve even tried setting the priorities of my L2 to high from the task manager(that really made things worse becasue when the L2 got active the whole puter froze)....any added suggestions cuz it really is tough to swallow a slow system. If only I knew what to do with it. Thanks for help ahead of time.
  5. NKNY


    Are you sure it's not your quote provider....?


    EDIT: I know you said your CPU gets maxed out but I like to blame everything on my quote provider...:D
  6. It's very possible that your quote-service has maxed-out their capacity.

    I am running Windows XP with the Hammer Platform from Assent, which is Cytrix client-based and it appears to be maxed-out right now and subject to "bottlenecks" which cause L2 freeze-ups and "catch-up" behavior.

    Assent promises a newer Cytrix version update by the end of the month. In any event, it really sounds like your data-feed provider doesn't have enough capacity anymore.

  7. Yeah, I heard about that from another assent trader. It sure sounds very similar to my L2 problem. Now you got me wondering if it is this VPN I am on that is causing the slowness. Any suggestions for a troubleshoot? Why do you assume it is my data-feed provider's lack of caapacity ? Thank yo uonce again.
  8. would this be Assents VPN in particular or a problem that all VPN connections have?

  9. Swish


    My 2000pro machine was really bogging down recently. I'd never deleted temp internet files and cookies. I had something like 28,000 cookies on my machine and who knows how many temp files. I deleted it all - machine runs much better......
  10. gnome


    Sounds like software problem... Usually when you have a CPU hog or resources hog, it's due to the data/charting software.

    Probably doesn't matter how big a machine or how much ram you have... the software will hog it all.
    #10     Sep 20, 2003