slow cpu?

Discussion in 'Hardware' started by bronks, Sep 22, 2003.

  1. Here's the deal. Months back I switched over to supposedly faster system. But it turns out that what I'm running now is a snail compare to my old machine. It gets especially bogged down when I run java applications such as TWS, Marketcenter (e-sig), etc. The problems start when I go between the internet and the apps. or between the java programs themselves. It also takes longer to fire up, open files, open other programs, shutdown, etc., etc., etc. I've cleared the cache, temp. files, defragged, disk cleanup, and ejected all viruses and spyware. It's running at 87% free resources.

    The computer I'm running now:
    Dell Dimension p3 1.0ghz/256mb ram 20gb hd. win2k pro

    Old computer:
    Compaq Presario 566 intel celeron/255mb ram 20gbhd. win98SE

    What gives??
  2. Thanks. OK I did as much as I could with this. However, I think the real problem lies in the java programs and how my system is interacting with it. Only because when I have these open is when the bugginess occurs.
  3. Are you running dual monitors?

    If yes, drag tws back to the no 1 monitor, maximize the window, minimize and drag it back to your no 2 monitor. I have to do this every day, otherwise there is some lag in the system. This started several months ago with a new tws version.

    The way I handle it is I bring TWS back to my Number 1 monitor at the end of every trading day. That way when I restart tomorrow, it starts up in number 1 and all is ok, drag it to 2.

    By the way I run a Plll 733 with 512 ram winXP and it is fast, very fast.
  4. Yes, I run dual monitors. Once the programs are up and running, everything is OK. But when I open the explorer browser on top of it, or another java program on top or underneath, or drag or minimize/maximize is when the fun really begins. I either get bits and pieces left here and there, stuttering quotes, delayed updates or things quit working all together. This doesn't happen all the time. Only when it's most inconvenient :) None of this ever happened on my old machine. I'll try your suggestion.

    EDIT: My internet speed is ALWAYS compromised when runing java apllications along side of it. I'd say about a 40% reduction in browsing speed.
  5. I recently closed my account with IB and deleted TWS and Sun Java from my hard disk. I have noticed that my lag has disappeared and java apps work much faster. Presumably Sun Java was causing the problems for my system.
    Hope this helps.
  6. Did you try what I suggested? (moving TWS from #2 to #1 then back to #2 monitor?)
    My cable speed zooms (tested at 1750 not 1500 as comcast claims) even with TWS problems here.
    I run several programs feeds and surf with no problems.
    Hell I even run my wireless laptop like this with no problems at the same time the desktop is running.
  7. The Following is a letter I received from IB Tech support solving this problem for me, maybe it will help you. I disable Java and now things work fine. I really wish IB would ditch this Java stuff and Use something else. Java Programs always slow my machine down, I really dislike them.

    " It sounds like a conflict between Java and your video drivers. There are a few things you can try.

    Get the most recent drivers for your video card
    Upgrade your version of Java. (the most recent is 1.4.1)
    **if you upgrade Java, be sure to uninstall old versions first & reboot If you are using the standalone version you can change the shortcut to disable DirectX
    **to do this follow these steps

    To do this, right click on the Trader Workstation 4.0 icon and choose "Properties". Then click on the "Shortcut" tab. In the "Target" field add the following line before the -jar


    So that the entire line looks something like this...
    (assuming that you have java 1.4.1_01 installed)

    "C:\Program Files\Java\j2re1.4.1_01\bin\javaw.exe" -Dsun.java2d.noddraw=true -jar C:\JTS\jts.jar C:\JTS

    -end of e-mail-

    I wish IB would make an alternate version of TWS without JAVA
  8. Yup. No difference. Rats.
  9. The main reason is looking at you right in the face: put in an extra 256 MB in that box, or even better an extra 512MB. After you upgrade, make sure that your paging file is set to at least 1.5 times your RAM size (and check that it is at least 384MB right now since you got 256MB RAM). W2K will run fine on 256MB, but when you start adding heavy-duty apps you're pushing it.

    Check in the BIOS that your CPU cache is enabled and if you run your monitors with cards that have less than 16BM on board, upgrade them.

    There are several other things that could be the cause of your problems, but do the RAM first and see where that gets you.

    #10     Sep 22, 2003