scottrade inlog probs with WinXPprof

Discussion in 'Retail Brokers' started by flapus, Apr 1, 2003.

  1. flapus


    I can't view my scottrade rtq anymore since I changed my operating system from win2kprof to winXPprof last week. When opening the scottrader v 1.009 window I recieve a message:
    load: class MainClassApplet.class not found

    I think it has something to do with the java but I am not a compwizzard...
    Can someone help me pls?
    What should I do to resolve my problem?

    Tnx in advance

  2. kowboy


    How about finding out what version of Java is used from Scottrade for the login window. Then download that version from the Sun Microsystems web site.

    If you are using Internet Explorer, go to "tools" then "Internet Options" then click on the advanced tab. Scroll down the list until you come to Java (Sun) and enable this by checking off the box. You will need to restart the computer to enable this.

    I am not sure the above will work, but worth a try.
  3. Scottrade streamer uses Microsoft Java VM. Do you have it installed?

    Do not know if it works with Sun VM (some applets from other brokers do have problems running on one or the other)

    Meanwhile, you can save yourself a lot of time effort and get more features in the process by just getting
    and using it to access Scottrade streamer data instead of their Java applet. QT is is a windows application, not Java, so you will not have the Java related issues.
  4. flapus


    I think that is the problem
    the incompatibility between ms and sun
    I installed some java stuff (but I am not a java expert so...) for the TWS (Ib) but I couldn't manage to install it or in any case to make it work...
    So in my internet options I have Sun java and Ms java

    before all this it did work but I hadn't installed the sun stuff
    so any suggestions to get rid of this prob?

    and quotetracker is no option
    I don't like the software and the interface
  5. Woody


    It sounds like a similar compatibility problem that I had between J-trader and IB TWS. One uses microsoft VM and the other uses Sun Java. I solved the problem by going into the "Tools" drop down in Internet Explorer and then selecting "Internet Options" and then the "Advanced Tab". From there make sure that Java (Sun) is disabled. I don't know if that will solve your problem, but it is worth a try.
  6. flapus


    When I am at home I will try it
    tnx for the info

    I know that both java Sun and Ms were on this morning when I left for work

    keep you informed
  7. flapus


    It works when I put off sun's java
    tnx a lot
    great forum

    the problem will be that I can't start my tws from IB because that works with MS java

    how do I solve that problem?
    1 screen scottrader and the other tws IB
  8. Woody


    IB TWS uses sun's java. TWS still works even though you have disabled it in the Internet Explorer