Router trouble? Think or Swim stopped working

Discussion in 'Hardware' started by earlyexit, Dec 10, 2012.

  1. I have an account with TDAmeritrade for my IRA stuff. Something weird happened over the weekend, and for the life of me I cannot figure out what is going on. Hopefully one of you guys have some suggestions.

    PROBLEM: While starting TOS software, it hangs as it checks for a new version of the software. I can close TOS with no problem. It just sits there like it is trying to make a connection and it never does. Do not get any errors either.

    Some debugging I've done:

    1) Internet connection is fine.
    2) Worked a few days ago. Did nothing to my computer or router since then.
    3) Laptop that has TOS on it does the exact same thing as my desktop.
    4) I can disconnect my router and connect cable modem directly into computer and everything works fine.

    Since #4 is true, you'd think it is a router problem. However, my internet connections are fine. I did not change any router settings. I've called TPLink tech support and they basically had no idea.

    Anyone have any suggestions, or do I need to buy a new router?
  2. no nothing about routers, but how about re-setting it and see if that works
  3. A few suggestions if you are using windows.

    Use command netstat -an in a command window on working and non working locations and compare the lists. Perhaps a port or protocol is being blocked. (type in netstat ? for help if you are not familiar with its usage already)

    Another suggestion is to upgrade your router firmware if needed. I believe that it is possible to have viral activity in a router in rare cases.

    I would take it to a buddies house or a coffee shop or several and try it on those. I have had a problem with a software when they upped the speed of my internet connection and it started creating reflections on some old connectors on the cable.

    I finally proved to the external company that my computer could tell which supplier of three it was (using my coffee shop idea). Only then did they admit that there was a problem which was detected by their third level support tech using a quality of service online check. By the way, a USB wireless connector worked for their second level tech who tried to tell me it was my issue.

    Root cause, a system upgrade over the weekend upped the speed so that my internal house wiring couldn't handle it. Re-running the cable fixed everything.

    I don't use TOS software but had a similar issue with my provider.

    Don't get me started on the quality of service of technical support!
  4. Thanks for the suggestions. Here are some things that I've done, that I failed to mention.

    (None of these made a difference)

    1) Installed new router firmware.
    2) Reset back to the default settings.
    3) Turned off all hardware and software firewalls
    4) I've taken my laptop to Starbucks. TOS works fine there.
    5) I've run "Active Ports" to see what ports TOS was using.
    A) I made note of them and added them to the list to be forwarded.
    B) Set the DMZ on my router to my desktop

    It really seems as if the router just "went bad" over the weekend. However, I find it strange that the router works for everything else but TOS. I'm close to buying a new router and just seeing what happens. But, I'd rather eliminate any other possibility I haven't thought of.

  5. gaj


    is it blocked by your AV or firewall before it gets to the router?
  6. FIXED!!

    Strangest thing. Just by chance, I decided to unplug all the wired ethernet connections into the router. Then ran TOS with only the one connection to my desktop. No go .

    Then, when I plugged all the ethernet cables back in, it worked.

    Have no idea what happened. Bad mojo somewhere.

    Thanks for responding!