remote desktop mouse lag? trading from brasil?

Discussion in 'Order Execution' started by esmjb, Jan 3, 2012.

  1. esmjb


    I live in LA and I trade estoxx futures using TT and clear through advantage. Mostly I point and click but I do use some automation and for the most part the lag from germany to chicago to here and back doesnt bother me. However, I'll be trading from Rio de Janeiro quite a bit this year and that distance combined with the generally poorer quality internet infrastructure is a different ballgame. I've already traded quite a bit on my laptop over the internet and it wasnt so great which makes me think I should put a box in advantage's office in chicago and remote desktop into it.

    ive experimented with that in the past (~2006) though and didnt like it, due to a significant lag in the mouse scroll. my question is has this tech improved such that no lag will be noticed? are there monitor limitations to RDP? i currently use a 30"-will that cripple an RDP's speed? does anyone have any helpful suggestions/solutions to my coming dilemma?

  2. You are connecting to the Eurex node in Chicago. Every Eurex node puts quotes out at the same time.
  3. esmjb


    this is both false and irrelevant.
  4. You are probably hurting yourself by using a remote desktop session. I host a few and rent/lease them to equity traders so I know at least a little bit about the space.

    I probably tell 10-15 traders a week that renting a remote desktop session isn't worth it if they are manually trading. In fact, you probably assume more risk because in the event of a disconnect you still appear to be logged in from your broker's point of view.

    You are also carrying the same latency with or without the RDP because the mouse click is back at the client machine vs. the host.

    Are you remoting into a server OS or a desktop OS?

    Try this:

    then right click on my computer, go to manage (run as admin) go to Services & Applications and then go to Themes, click disable and stop - hit Apply & OK.

    when you start a RDP session click on options and expand the menu - go to Display tab - turn down the color as much as possible without things looking weird.

    Under Local Resources:

    remote audio - kill it all
    Local devices & resources - uncheck them all

    Under Experience - select accurate connection (probably 56k or low-speed broadband)

    good luck - what do you do if you are in a location that drops and you lose connection?
  5. esmjb


    thanks for the response.

    i would be remoting into a desktop OS.

    i guess i dont understand why i should operate locally. if the lag is the same in both cases and about 30% of my trades are automated then it seems obvious to me i should operate remotely so my automation doesnt have to deal with ~2.5 rt times to brasil. what am i missing?

    also if my connection drops, as it does more than i'd like in brasil, whats the difference if im local or remote? i have to call eurex either way to cancel orders. its possible my automation keeps firing when i dont want it to but given its directions im not really concerned about massive losses from that.

    please anyone with info/experience keep the responses coming!
  6. Mr_You


    You're correct that a remote desktop would work best if you're automating.

    Follow WinstonTJs suggestions. Also if possible make sure you're using the latest Microsoft Remote Desktop technologies. The latest version of the client appears to be v7 and requires XP SP3, or Vista SP1, or Vista SP2. It may also be beneficial to be running Windows 7 or Windows Server 2008 as your remote desktop OS.

    Bottom line, international internet connections are going to have higher latency and there is not much you can do about that.
  7. esmjb


    does size of monitor make a meaningful difference when RDP'ing?