QuoteTracker having mini seizures...

Discussion in 'Trading Software' started by Gord, Jun 19, 2008.

  1. Gord


    Been using QT for a couple of years and recently decided to explore swing trading (I normally day trade). This meant opening quite a few more charts. But when I get up to ten running QT begins to studder and freeze. The feed continues OK, but working with the charts (moving them, drawing, scrolling, etc.) becomes a lesson in patience. Every few seconds the program freezes for a fraction of a second. It can also be noticed in the moving bar indicator beneath the feed connect button - it stops and starts in coordination with the freezes. The problem is definitely connected to the feed, as when I turn the feed off all functionality returns to the charts - but of course no updated data.

    Here's what I have tried:

    Discussed this with Jerry

    Updated QT

    Tried two older versions of QT

    Switched on and off every option in QT

    Switched between IQ Feed and IB feed

    Upgraded and downgraded Java

    Fresh install of Windows OS

    Turned off all optional Startup programs

    Tried it without ButtonTrader or IB WorkStation running

    Tried bashing my head against the wall - that just damaged the wall [​IMG]

    Anyone have additional suggestions?

    Anyone else have this problem?

    Anyone had this problem and found the solution? [​IMG]
  2. Invest in a real charting program, Problem solved!
  3. I$land


    - Add more RAM to your PC.
    - Add your QT folder to your anti-virus list of "excluded folders"

    If that doesn't work, change PC and/or trading software :)
  4. Gord


    I just knew some know-it-all would have the answer... [​IMG]
  5. Gord


    Got lots of RAM.

    I tried it with the anti-virus off, but perhaps it still might affect it in the background. I'll try your suggestion.

    Thanks... [​IMG]
  6. I$land


    I used to have about 10 charts running on a dinosaur PC so you should be able to.

    What I did on this computer is reduce the number of intraday days loaded for each chart. There is an option somewhere that goes up to 10 days. Try putting 1 or 2 see if there is any difference. Also, there is another option where the intraday data is automatically saved every x minutes. Try turning this option OFF (or set the save time to every 1000 minutes).

    I know you said you have tried turning many options ON/OFF so you may have already tried all of these suggestions already.
  7. I run QT and Amibroker with 6 charts up on the futures with no problems ever.
  8. Excellent Commentary

    When you have issues....also check your datafeed by running a tracert command to your data servers....

    Also issues can be internet based....and you may experiment with various numbers of watchlists, etc...

    Sometimes when I have hesitancies....it is data feed/internet issues....

    I often see those ****** on the tracert....
  9. Gord


    I tried the anitvirus exclusion, but that didn't help (was a good idea though). Tried reducing the number of intraday days also - no luck. Don't see an option for saving intraday data.

    In the past I have had up to fifty intraday charts along with trading platforms, browsers, etc., all running without a sweat. Computing power is not my problem. There is an incompatability somewhere.

    Thanks again for your input.
  10. I have got the same problem on a rather old PC though, QT can get very slow especially if I let it idle all day. That's with aboutr 20 mini charts spread on several monitors . The more symbols you have updating in RT in your portoflio, the bigger the charts the slower in my experience. QT defintely got much slower about a year and a half ago with IB .

    I am also having intermittent problems with IB backfill recently , anyone has had the same experience? Is it because I upgraded to the new TWS ? It wouldn't surprise me.
    #10     Jun 19, 2008