Problem connecting to Genesis software

Discussion in 'Trading Software' started by Bluedog, May 4, 2006.

  1. Bluedog


    I have been thinking about opening an account with Genesis but I simply can not connect to the Laser software! The tech support is suggesting I should switch my internet provider from DSL to cable.

    I remember seeing a couple of threads a while back on the same subject as well...

    Any suggestions from current users?!

  2. what time of day were you trying to connect? Try connecting during market hours
  3. Bluedog


    During market hours.

    Keep getting "Executor connection lost!" message" every time.. I have tried on both computers I have with the same result..
  4. Always try during market hours. Try resetting your dsl modem: switch off your PC, switch your router and dsl modem off, leave everything off for 1 minute then switch dsl modem and router back on and then switch PC on, and see if that changes anything. If you have a regular dialup modem somewhere or a WIFI connection somewhere, try connecting through that just to see if that changes anything. It could also be related to antivirus programs or firewall programs or the windows firewall blocking the ports needed to connect to Genesis servers...
  5. Bluedog


    I was using DSL with a router, Genesis tech support told me the problem is with my DSL so yesterday I got cable. The result is still the same!

    I disabled Zone alarm, Norton and Microsoft antispyware and still no luck! :mad:
  6. Try from a totally different PC somewhere else, to make sure the username and password are valid. I know it's a long shot, but its possible, just try ..
  7. I haven't been able to connect all day.

    I can't connect at all.....

    I have not traded all day.

    I was thinking it might be an issue at my firm.... but I can't connect to anything....

    First time ever had an issue like this....