No sound.....S.O.S.

Discussion in 'Hardware' started by imc, Aug 10, 2006.

  1. imc


    I have re-formatted an old pc and everything works fine except I cant get any sound, the speakers are ok.
    When I try to install the sound card drivers from the original cd there is a message telling me the 'operation failed'.

    Any help would be appreciated.

  2. Sanjuro


    Look on the net for the latest driver for the old soundcard for the pc and give it a try.

    Worst case if the sound card really failed, you can purchase a old cheap soundblaster card and put it in.
  3. imc


    Hi, thanks for the quick reply, how do I find out the name of the sound card installed on my pc?
  4. Sanjuro


    If you bought it from Dell or one of the big names, you can get the drivers straight form their website under Support/Drivers.
    If you still have the manual, it may tell you.

    Either you have a separate sound card that plugs into your motherboard or it's an generic integrated sound card. Then you would get the drivers from the motherboard designer's page like ASUS, ABIT, Intel.

    Another choice would be to get a new computer. :)
  5. imc


    I have managed to download drivers from the makers web site; c-media ac97
    but the sound still no work...doh!

    A new pc as well as a new window that was damaged when I threw out the pc!!
  6. No yellow ExclamationPoints in the DeviceManager? You open up the AC-97 device and it says driver installed and operational?

    Check your volume/mute settings. And make sure the speakers are plugged into the proper socket.
  7. imc


    Yes, I get the yellow exclamation mark but the message says 'device not started' - code 10

    I have tried deleting it and restarting with the driver disc but it still wont start, I also dowloaded an updated driver and still no go!

    Speakers work ok, maybe a faulty sound card?
  8. Soundcards are notorious for IRQ conflics. In the DeviceManager, pick ViewByResources and open up the IRQ listing. See what IRQ the soundcard is using and see if there's any others using it.

    Most likely, you may have a non-plug&pray sound-card that uses hard-wired jumpers to pick IRQs. To make it work:

    1. turn off machine and pull out the soundcard and see if there are jumpers to pick the IRQ. Most common settings are IRQ 5 or 9, I prefer 5.

    2. boot-up machine and get into the BIOS (hit F1 or Del or whatever keys needed on boot).

    3. go to menu like PCI/IRQ/Plug & Play settings. There should be a list of available IRQs with settings like Auto/Reserved/ISA, and pick Reserved or ISA for IRQ-5 depending upon the motherboard BIOS. This makes Windows not try to use that IRQ for any other device.

    4. reboot and see if driver works this time. Might need to uninstall device driver, reboot, let it re-detect and re-install driver with proper IRQ selected. You might even need to open up DeviceManager afterwards and go into Driver and manually set the IRQ to the same one you set on the jumper on the soundcard.

    P.S. I've seen driver .INF files cause confusion for Windows. Some manufacturers puts ALL of the files into one directory and Windows doesn't correctly parse them properly (Win9x drivers are set up differently than WinNT/2K/XP). If this is the case, rename the Win9x .INF files to something like .W9x so that Windows2K/XP only looks at the correct ones (open up .INF files in WordPad and read first couple of comment lines). Otherwise, if your driver disk is nicely divided into Win9x, Win2K, WinXP, SCO, LINUX, etc. folders, make sure you point the DeviceInstaller to the correct folder when it detects teh card.

    What a mess... get a Mac! :)
  9. Run Linux!