Network Wizards Please help Again ??/

Discussion in 'Hardware' started by Digs, Sep 11, 2003.

  1. Digs


    See my network design attached....

    Ok here is what I want to do ...

    PC1 gets data via a program ( subscription cost ) , I have another program on PC2 that reads it and calculates with it...I want both PC's to access the internet via the ADSL router...

    In PC1 the Data is stored in "C:\Data" folder ( sharing options turned on to full ), this folder is mapped in PC2 as "F:\". I want my PC2 software to access the data via the "F:\" drive over the 1 Gig cross over line. ISSUE : Somes times PC2 "F:\" goes the other way via the ADSL router, hence it is slow, and it hinders the data coming into PC1. Of couse I realise my design is a network loop.

    NOTE : I can fix it manually by TURNING off the Lan1 which connects the ADSL router to PC2. BUT then I do not get the internet on PC2.

    QUESTION : Is there a way that I can SET or FIX that mapped drive "F:\" on PC2 to get the data along the cross over 1 GIG cable and not any where else...and if that connection is disabled then dont get the data ?????

    I do not want to have PC2 get the internet over the cross over cable and hinder the data collection functions of PC1 via its Lan1 then the ADSL router, rather have it go direct to the router...
  2. You have twin NICs in each machine? I'm no network guru, but my thought is your DSL router would also do what you want without the direct connection of the two machines, i.e. they should share data between them through the router.
  3. Ninja


    Well I can't help him with his problem, but you can bet that he wants to keep his fine 1 gig cross over cable for massive, fast data transfer between the two machines... :)

    If we are talking about a Windows OS then I would guess he needs to enter a static route (ROUTE ADD) for the second NIC.
  4. A simple question here.

    If I'm on my main PC and go to Windows Explorer then click on the network tab to see the other PCs on the network, on one of them I can't get in because it always asked for a password.

    The trouble is that it never used to. How do I turn this password request off?

  5. CalTrader

    CalTrader Guest

    The gigabit device needs to be mapped to a particular IP address and a static route needs to be set up for this IP address and the transfer software need to be told to only use this network.

    The other issue with password is simply a security issue: your logon account needs permissions on the machine that keeps presenting a password dialog. Adjust these via users/groups.
  6. Bsulli


    In your original post you state that sharing is set to full so I'm assuming you have file and print sharing for Microsoft networks enable on both interfaces in each pc. Disable it on the 100mb interfaces in both pc's and leave it on on the 1gig interfaces. That's one way and the easiest.

    Second way, along with the first is under propteries for 100mb interfaces on both pc or only one pc for a matter of fact, select properties on the TCP/IP, click on advance, now click the "Wins" (All drive mapping is done thru Wins) tab on the top, then click disable Netbios over TCP/IP. You will probably have to restart the pc's after these two changes in case the flow was currently across the 100mb interfaces.

    Microsoft uses netbios as the protocol for file sharing(drive mapping), specifically they use ports IP 138,139 for transport. They were one of the main authors at the IETF for an RFC that created the encapsulation scheme for netbios over TCP/IP protocol specifically for being able to continue the use of Wins without having to maintain an older protocol developed by IBM called Netbeui.

    As for adding static routes that won't help because each route/interface is only one hop away. Microsoft's uses a routing protocol called Ripv2(if routing isn't enable under properties, if enabled they use OSPF)) for route discovery amongst pc's. The actual problem isn't a routing it's a Metric problem. Goto a Dos prompt and type "route print" return to see all of the routes out each interface. The routing table will show the routes across the gig interface already so adding a static will only help if the metric is changed. The metric represents the routing cost across that path and would require actually raising it on the two 100mb interfaces to metric of 2 and leaving the gig at one. The lower the number the cheaper the cost to route. There by being the route the share net maps will take. Access to the internet won't be affected by the higher cost. But then you will have static routes out those interfaces which if using DHCP for addressing this will be a problem if enter inproperly

    Currently MS doesn't support application steering at the OS level, but some individual programs do, but generally most just rely on RIPv2 for the most cost affective way to get between points A and B.

    One other thing that can effect mapping is called "Browse Master" it's on by default in all MS pc's. As each one is turned on it will force an election amongst the pc's to determine who is the master. Even if you leave them on 24hoours per day they will still do an election periodcally. You can disable it on only one of the pc's and the elections will stop. This generally won't cause the problem your seeing unless the paths of the map drive data flow is switching during normal opertions.

    Bsulli, former internet backbone routing consultant to MCI.

    Good luck.
  7. If you are not a network wizard, then you are definitely going about this the wrong way. In fact, even if you were a network wizard you are going about this the wrong way. You need to do 2 things;

    1) Disable or uninstall one network card from each machine and throw away those archaic crossover cables.

    2) Get your cheap ass out to any store that sells computers and buy an $80 internet router.

    Damn near every trader I know has more than one machine and usually they are sharing data somewhere. In other words, everyone has your exact same problem!!! Any cheapo Linksys router will do exactly what you need. That is the whole purpose of an internet network your computers together and to the internet at the same time. You are not only going about it in a complicated manner, but a poorly thought out manner as well.
  8. Digs



    The cross over cable is 1 GIG fast, the internet is on 100 mbps so guess which one I want to have data transfer on...

  9. Digs


    From another forum...WIZARD13 posted this solution, so what do you think...

    Do the following and you should be able to fix it.

    100Lan: IP, GateWay, SB Mask, DNS your provider's
    1GbitLan: IP, Gateway, SB Mask, no dns needed

    100Lan: IP, GateWay, SB Mask, DNS your provider's
    1GbitLan: IP, Gateway, SB Mask, no dns needed

    IP, GateWay or the one given by provider, SB Mask, DNS your provider's

    EDIT: IP addresses are for example, you could use 192.168.x.x if you like and to be sure for the route, connect the drives using ip addresses and not names
  10. Digs


    and SKI from the same forum posted this ....

    The easiest way I can see to make what you want to do work is to disable NetBIOS over TCP/IP, and then create a Hosts or Lmhosts table for each PC, relating their names to the IP address of the GigE NICs.

    Perhaps there is a way to create a routing table entry in each PC that creates preference for the GigE link, as well (this is something I've never tried, but I think it's do-able). This would retain the PC's ability to communicate with each other if you lose the GigE link, but result in them comm'ing over the GigE link whenever present, and allow you to run NetBIOS over TCP/IP.

    On the whole, the first solution seems to be closer to what you're asking for. Google for more info: see links below as well...

    Edit: remember to configure the GigE NICs to use ONLY the Hosts/Lmhosts file (NO DNS or anything else except basic TCP/IP: you'll need to go into advanced TCP/IP config to get everything right). You're correct to be concerned about creating a loop in your LAN: you can easily inititate a broadcast storm if you goof the configs up when trying this...
    #10     Sep 11, 2003