Internet Connection But IE Won't Access Internet

Discussion in 'Trading Software' started by CET, Oct 31, 2010.

  1. CET


    I am helping my neighbor with a problem with his Uverse service. The internet service worked fine for almost a year on a desktop that uses home networking via the electrical wires to access the residential gateway/router (RG). A few weeks ago the desktop could not be assigned an IP address by the RG. The desktop finally had to be manually assigned an IP address to get it to connect to the RG. Whether the home networking or wireless card is used on this PC it now says that there is a connection, but when you open Internet Explorer you get the message that the web page cannot be displayed.

    Is it possible that there is no connection to the RG even though it says there is? If that is not possible then what could cause this problem with IE not accessing the internet. FWIW, I tried to access several different web sites with no luck. Also, once the connection to the RG was supposedly established the Uverse technical support folks said they could not assist with the IE problem. No surprise there.

    I would appreciate any suggestions on the IE problem. TIA.
  2. GTS


    From the machine with a problem open a command prompt (CMD.exe) and do "ping" if that works (reply received) then you know have internet connectivity

    Next test - make sure DNS is working. Ping

    Another thing to do is to install a different browser (firefox or chrome) and see if that works - if it does then you know the problem is specific to IE and not the whole OS

    When you manually configured an IP address did you remember to define a default gateway and DNS servers? These are normally supplied when you pull a DHCP address from the RG. Without those you wont be able to reach the internet but you would still be able to reach the RG since its on the same LAN segment.
  3. The problem seems to be on the RG - his gateway/router.

    I don't think manually assigning the IP on his computer will work. What IP did you use? If your RG device doesn't have an IP itself (assigned by the service provider), it probably cannot be connected to the Internet.

    Who provides this RG device? Is it part of the Uverse service? Provided by AT&T?

    I have pretty good tech support from AT&T on the DSL service. I am surprise if they can't help you with the Uverse service (I don't have it... and don't even know what it is...)

    His computer is connected to the "network"... which is only between his computer and the RG device. The RG doesn't know how to relay the IP packets to the rest of the Internet... then it is useless.
  4. CET


    I did the ping test, and it did not work. The request timed out 4 times and gave this result: Packets: Sent=4, Received=0, Lost=4 (100% loss).

    FWIW, here is the info on the IP address that was manually assigned under the TCP/IP properties:
    IP Address:
    Subnet Mask: (this was populated automatically)
    Default Gateway:

    I was not given any info to use for the DNS Server Address. Also, the IP address on the back of the RG is This may not mean anything, but I wondered if the Default Gateway should be the same as the IP address of the RG. I was given one that ends in 245 while the RG address ends in 254. I changed the Default Gateway to end in 254 instead of 245, but this made no difference when I ping tested it. It may have made no difference because there is no DNS Server Address info, but I guess I need to know if the Default Gateway Address should match the RG address for when I get some DNS Server info.

    Thanks for any more info you can provide.
  5. CET


    The RG is part of the Uverse equipment and is supplied by AT&T. The RG works, because a laptop is accessing the internet with a wireless connection.

    Once AT&T believed the connection was working they said it appears to be a PC or internet browser problem and this is not their responsibility. Then they kindly offered to transfer me to their fee-based computer support group. It appears the tech to which I was speaking did not know enough to suggest the Ping test to make sure there was a connection.
  6. Yes it is

    I have no experience with uverse but found this guide for setting it up.

    Before you ping other addresses, can you at least ping the router?


    Do you get a reply from the router?

    If you don't, the RJ-45 cable you/he used may be no good. If it is the cable:

    1. Can be a faulty cable.
    2. The wrong type of cable.

    To plug in from the PC to the router, you need to use a straight-through RJ45 cord. If you happened to use a cross-over RJ45 cord, it will not work. Cable is the first thing to check.

    Unplug the cord and take a look at the end. Did they look like straight-through or cross-over?

    Take a look at this diagram: (The top one)

    PS: Also, I think it is a bad idea to assign IP address manually. The router should be able to assign the IP address to the PC if configured or working properly. If you assign the IP address manually, you would also need to register the DNS server addresses on the PC.
  7. GTS


    The desktop default gateway should be set to the RG, so set it to on the desktop.
  8. CET


    I pinged the router and got no reply. It timed out. FWIW, the internet access on this desktop worked fine for almost a year using the Plug Link home networking supplied by AT&T. This uses the house electrical system, and appears to be a modified electrical plug with an ethernet cable that plugs into the PC Network card and a different one that plugs into an ethernet port on the RG.

    I don't know if a setting in the RG got changed that could affect the the ethernet portion while allowing the wireless access to work. Their laptop works fine using wireless access. AT&T actually sent out a wireless card for the desktop, but the connection does not work even though it says it is connected with a strong signal. I switched the PC back to the Plug Link/ethernet set up and this connection what I am currently trying to make work.

    Thanks for any other info on this problem.
  9. I had a similar problem a couple of weeks ago and it was driving me crazy. I ran my usual array of spyware programs: Spybot, Malwarebytes, CCcleaner, SuperAntiSpyware, etc. Nothing helped.

    Did the manual IP resets, but they would be changed. I did a combinatin things. With the help of a friend we connected an adapter he had that connected to my wireless router and to a usb port. We could then connect to the internet. Something was in the startup programs that kept reinstalling this but. Once connected we updated all my spyware programs and restarted in safe mode. I ran Rkill and then all the others. Still had a prolem. Downloaded AVG trial version and it found 4 files that it identified as malware. I deleted those, did a manual IP reset and rebooted. Poof. Problem gone. Must be a simpler way, but that is what I did.
  10. GTS


    It sounds like it is the ethernet over power (pluglink) that is causing the problem. I would try plugging directly into the RG with an ethernet cable (using a laptop if connecting the desktop is a problem) to confirm that that works (using DHCP not a manually assigned IP) If that works then I think its a problem with pluglink system.
    #10     Oct 31, 2010