Interactive Brokers delaying market orders?

Discussion in 'Order Execution' started by grainmerchant, Feb 7, 2013.

  1. Is this a good thing? i had an alert pop up today saying that i was subject to a 'cap' and a 'floor' on my market order ??? WTH?
  2. Bob111


    heh...where have you been?

    11-21-12 11:55 AM

    don't worry..IB acting lately just like US gvt..they will "take care" of you and your are protected by their market cap feature.
    works really well when your stop is triggered :p
  3. NoBias


    Elect to Bypass Auto Market Capping
    Select the Bypass market cap checkbox in the Settings area of the order Presets to disable the price cap for buys and price floor for sells that TWS automatically applies. This price check is a precautionary feature that will be applied if an order price is outside what is considered fair or consistent with an orderly market.


  4. Bob111


    -- outside what is considered fair or consistent with an orderly market--

    yeah. those are good intentions,that might not work for everyone. specially in markets we have size doen't fit all(but at least they have disable button). the problem is that on thread above-it kind of enabled by Ib. one day you didn't have pop up-next day-we do.

    define fair and consistent price on sucker like this one(and more and more US stocks looks like it as volume dries up): :p
  5. Thanks NB. I'll try to disable it.
  6. J.P.


    Thanks, NoBias, I've been trying to get around exactly that. However, my 'Bypass market cap' is grayed-out and unable to be selected on any screen. Now why is that?
  7. NoBias


    It doesn't apply to all products. i.e. Structured product, Forex, Bills, Bonds, commodities I believe... Going from memory, so needs to be confirmed...

    I would imagine thin instruments mainly... but that is an assumption

    Edit: reading your post again closely, I believe you say all your instruments are non selectable i.e. can not elect Bypass Market Cap.

    This is most likely due to other setting in your configuration. Suggest just giving IB a quick call to confirm...
    [perhaps you have Time in Force "DAY" and not "GTC" selected, just a thought]

    Edit2: I was curious and do not like providing mis-information so made a quick call to confirm.

    Bypass Market Cap does not apply to all instruments. i.e. Forex
    The reason for greyed check box can be a multitude of reasons. You will need to contact them yourself...

    Good luck, Trade well
  8. J.P.


    I switched from DAY to GTC, as well as various other selections, none helped. Although I hate doing it, at your suggestion I opened a ticket at IB. We'll see what happens. Thanks again.
  9. Bob111


    i guess Ib is just disabled them on their side,after all those complaints and sudden pop ups. but that it wouldn't explain problems in original post.
    #10     Feb 8, 2013