IB TWS Can't log in 3/16/04

Discussion in 'Trading Software' started by prophet, Mar 16, 2004.

  1. prophet

    prophet

    TWS should have connected 10 minutes ago.

    I'm seeing the same behavior on two servers, in different locations, different OS's (Win 2000, Win 2003). Both are giving the same log file:

    00:06:43 JTS-Main: Started on 3/16 at 00:06
    00:06:43 JTS-Main: Build 819.3, 2004/03/10 10:00
    00:06:43 JTS-Main: applet = false
    00:06:43 JTS-Main: host = gw1.ibllc.com
    00:06:43 JTS-Main: remotePort = 4000
    00:06:43 JTS-Main: localPort = 0
    00:06:44 AWT-EventQueue-0: username = S_______
    00:06:44 AWT-EventQueue-0: Setting dir is C:\Jts\
    00:06:44 AWT-EventQueue-0: Connecting
    00:06:44 JTS-Login: Creating socket
    00:06:44 JTS-Login: m_encryptCollision = false
    00:06:44 JTS-Login: Local port=1618
    00:06:44 JTS-Login: Peer=4000
    00:06:44 JTS-Listener1: Starting listener
    00:06:44 JTS-Listener1: loginSuccess

    (Login prompt hangs as if it is trying to log in)

    Anyone seeing this too? Any workarounds?
     
  2. The US server is shut down for one hour each night about this time for restarting.
     
  3. lol
     
  4. def

    def Interactive Brokers

    I just logged in and placed a test order. Did you try contacting the help desk? If you downloaded 819 today, try rolling back or logging in via the browser to see if that helps.
     
  5. prophet

    prophet

    I normally use TWSStart to restart TWS automatically each night between 11 and midnight CST. Version 819.3 appears to be incompatible with TWSStart. Starting TWS manually workes fine. I wish I had figured this out before losing 30 minutes of data.

    So the problem is with TWSStart. Anyone else use TWSStart? What version do you use? Is there a better utility out there? Is there any way to make TWS persistently try to connect and automatically log in?
     
  6. prophet

    prophet

    Yes, rolling back to 818 fixes it. Starting TWS the usual way (desktop icon or start menu) allows version 819.3 to work properly.

    The problem is that starting with version 819.3 the TWSStart utility is no longer able to start TWS. This configuration has worked fine for the last 6 months. I had gotten accustomed to letting TWSStart restart TWS for me, never needing to start TWS manually.

    Thanks for your help!

     
  7. The TWS install for 819 rewrites the startup string on your desktop icon, but not for the icons in your Start Menu (the pin list of frequently used programs) or in your Start Menu>All Programs>Trader Workstation 4.0 menu item.

    You can use the desktop Icon OK but not the other two menu items. You need to rewrite the startup string for those items to be similar to what the TWS install gave you, but be careful because the TWS install program points TWS to the IE default JRE which may differ from the JRE you would want to use.

    The 819 distribution has new jar files in it. You are going to have to edit the startup strings in TWSStart and your other (non desktop) icons to reflect the new jar files referenced in the TWS Desktop Icon's startup string. It works fine once you do that.
     
  8. BKuerbs

    BKuerbs

    Looks like I got some other problems: I upgraded this morning to 819, could not login. I downgraded to 818, could not login.

    I then switched to the browser version TWS 819: this works fine???

    I do not use TWSStart.

    Have a nice day.

    Bernd Kuerbs
     
  9. prophet

    prophet

    Indeed the startup string changed from:

    (TWS version 818 and previous)

    "C:\Program Files\Java\j2re1.4.1_03\bin\javaw.exe" -jar C:\jts\jts.jar C:\jts

    to

    (TWS version 819)

    C:\WINNT\system32\javaw.exe cp C:\Jts\jts.jar;C:\Jts\jcommon-0.9.0.jar;C:\Jts\jfreechart-0.9.15.jar jclient/LoginFrame C:\Jts

    TWSStart is apparently hard-coded to run the first string. I wonder if I merged those jars into a single jts.jar it might fix this problem. I won't do this though. Probably better to change the settings for TWSStart.

    TWS version 819 copied javaw.exe to C:\WINNT\system32. What does this accomplish?

     
  10. You need to rewrite your startup string to reflect the changes in the TWS desktop icon as I described above. Did you start TWS from the desktop icon? It would have worked. Perhaps you tried to start from the Start Menu. That would not have worked.
     
    #10     Mar 16, 2004