IB TWS Asian Server Backfill Problems?

Discussion in 'Retail Brokers' started by kiwi_trader, Dec 18, 2006.

  1. I have had problems downloading IB backfill data for the last two days. Just from the Hong Kong server.

    Is this a known issue?
  2. Me and a mate are having that problem kiwi ... I contacted chat after i saw your post ... and they were very polite but a bit of a waste of time:

    ChatSys: This chat is associated with ticket #xxxx. Please record this number for use in future inquiries. You are currently in room 'General '.
    Louis C: Hello, this is Louis. What can I help you?
    me2ib: hi louis
    me2ib: i am a hk server connected customer
    me2ib: my backfill for hsi and sgxnk hasn't worked well for last two days
    me2ib: is this a known issue?
    Louis C: let me check.
    Louis C: what is the backfill period?
    me2ib: even a few minutes was a problem .... ie yesteday i was getting "todays data"
    Louis C: HSI index or future?
    Louis C: what is the TWS version you are using?
    me2ib: hsi futures (dec) and sgxnk futures (mar)
    me2ib: I am using 860.9 but my friend who has the same problem is using 865 and had the same problem with 864 and upgraded to see if it would go away
    me2ib: i am in Australia ... hes in South africa
    Louis C: my chart on HSI looks fine. i'm pulling up 1 week chart on bid/ask ...
    me2ib: no ... u are using tws charting (which is very limited) ... i am using sierrachart which calls for the data over the api
    Louis C: guess its time for you to upgrade your TWS. however we aware that there are some problem with our latest 865.2 ( in standalone login). but the problem was fixed in our browser base login ( 865.4)
    me2ib: no
    me2ib: my friend has upgraded and it didnt fix the problem ... something must be wrong with the hk server
    Louis C: ok...if thats the case guess you need to contact our API team regarding this.
    me2ib: everything worked fine last week
    me2ib: OK .. I will post this on elite trader and see if i can get some attention to the problem that way.
    me2ib: Have a nice day Louis. Cu.
    Louis C: you too...
    Louis C: Please feel free to return to chat if there are any additional questions.

    I wonder if someone from IB who actually knows something could contribute here?
  3. mg_mg


    Just let you know that I can pull out HSI 200612 from HK server for the period from Dec 10 successfully. My API version is 8.70. So it is either the HK server recovered from a failure or it is a problem with the software you use.
  4. mg,

    How do I check the api version?

    I'm using Sierrachart but also tried with Quotetracker and it wasn't great either.

    I suspect its not my software because nothing changed since last week (when it worked wonderfully!).

    Found a file API_VersionNum.txt and I'm on 8.85 .... I suspect that support would tell you to upgrade your version :)
  5. mg_mg


    Hi, Kiwi, after I updated to version 9.00, I made the same request (HSI 200612 from Dec 10, server is gw1.ibllc.com.hk), and it is successful. Yes, API_VersionNum.txt telsl which version is used. Below is a portion of log file.
    01:47:34:195 AWT-EventQueue-0: Generating request for: HSIZ6@HKFE
    01:47:34:255 AWT-EventQueue-0: HMDS Query attempt occurring
    01:47:34:756 JTS-EServerSocket8: Sending sec def req by symbol for HSI 0 HKFE FixSecDefReqBySymbol404
    01:47:34:766 JTS-EServerSocket8: [1:23:27:1:0:0:0:ERR] Invalid incomming request type - 0
    01:47:35:006 JTS-FixDispatcher-7: Handling sec def FixSecDefReqBySymbol404
    01:47:35:006 JTS-FixDispatcher-7: Generating request for: HSIZ6@HKFE
    01:47:35:006 JTS-FixDispatcher-7: HMDS Query attempt occurring
    01:47:35:006 JTS-FixDispatcher-7: Sending HMDS message
    01:47:35:006 JTS-FixDispatcher-7: Getting hmds route with HKFE and FUT
    01:47:35:006 JTS-FixDispatcher-7: Sending routed HMDS message
    01:47:36:959 AWT-EventQueue-0: Generating request for: HSIZ6@HKFE
    01:47:36:959 AWT-EventQueue-0: HMDS Query attempt occurring
    01:47:37:680 JTS-EServerSocket8: Sending sec def req by symbol for HSI 0 HKFE FixSecDefReqBySymbol405
    01:47:37:680 JTS-EServerSocket8: [1:23:27:1:0:0:0:ERR] Invalid incomming request type - 0
    01:47:37:980 JTS-FixDispatcher-7: Handling sec def FixSecDefReqBySymbol405 
    I don't know why there are two invalid incomming request error shown up there, probably type = 0 means every thing is normal.
  6. Its been fixed now so someone must have paid attention and fixed the servers. Even when you can't get through to the CS people someone can hear.

    Thanks IB :)