IB disconnected

Discussion in 'Retail Brokers' started by ADX_trader, Jan 12, 2004.

  1. Are your IB connection OK today (12 Jan 04)? I have many disconnections!
     
  2. No problems here in Europe (swiss server).
     
  3. BVM88

    BVM88

    I came here hoping to find a solution to my disconnection problems and see that I’m not alone. For the past 3 working days my connection has been resetting itself 3 or 4 times per hour and occasionally I lose it entirely. The data feed is also forever starting and stopping. The problem may or may not stem from IB, so if I may, can I ask if anyone has had issues with software/hardware that interfered with their IB connection.
    BTW I'm trading Eurex through the Hong Kong server.
     
  4. I'm on the HK server too and have maybe 1 or 2 30 second disconnects in the last week. I very rarely have connection problems unless my ADSL is playing up.
     
  5. Try turning off ssl and see if it improves your connection. Mine did but I cannot say if that was really the reason. I still have occasional very short disconnects but not the frequent ones before.
     
  6. TWS- various probs & a solution
    (file corruption in TWS XML folder results in flakey connections and other problems)
    http://www.elitetrader.com/vb/showthread.php?threadid=26361

    Ethernet cards which may conflict with Java sockets connections
    (some have had probs with the Linksys card)
    http://www.elitetrader.com/vb/showthread.php?s=&postid=372891&highlight=tws+network+card#post372891

    Video card Java conflicts (disable direct draw)
    http://www.elitetrader.com/vb/showthread.php?s=&postid=372955&highlight=tws+video+card#post372955

    Make sure you have the latest Java Runtime environment installed AND the TWS is actually pointing to it (installing the JRE alone is not enough). Right click the TWS icon, go to Properties and edit the startup string to point to the JRE you want.
     
  7. BVM88

    BVM88

    Many thanks guys, you’ve given me much to consider.

    Happy hunting
    BVM