IB - changing default for smart to go to ISLD?

Discussion in 'Order Execution' started by gaj, Sep 8, 2013.

  1. gaj


    i'm on IB, fees are bundled together.

    sometimes i'll place a hidden order. if i use SMART, a chunk of time it goes to BATS and has a low probability of getting filled. if i direct route to ISLD, it has a better chance of getting filled.

    so, i'd like to have my initial default routing for SMART to always check ISLD first.

    is there a way to do that?

    i checked edit / global configuration / smart routing and don't see anything. all i see there are exclude exchange with non-firm (unchecked), exclude exchanges with non-electronic (unchecked), Maximum allowed from NBBO (blank), seek price improvement (unchecked), pre-open re-route (unchecked), smart multipurpose (default checked, display checked but greyed), smart highest rebate (both unchecked).

  2. IBsoft

    IBsoft Interactive Brokers

    Try setting the smart routing preference to: "highest volume exchange with rebate".

  3. gaj


    thanks IB, but i don't have that option? i have:

    SMART Option Routing Algorithms

    Default Display
    (check) (greyed, checked) SMART Multipurpose (SMART)
    (uncheck) (uncheck) SMART Highest Rebate (SMART Rebate)

    it has above that information about Destination, but i don't have that drop down selector.
  4. IBsoft

    IBsoft Interactive Brokers

    You need to switch to cost+ (aka unbundled) commission schedule, and you will get those options. Your other option direct routing.

  5. gaj


    ok, thanks for letting me know. i'm not switching, so i'll just do what i've been doing (with direct routing). i just remembered at one point, there was an option - i think for BATS - to exclude it for SMART, or maybe put it down on the list, or something similar.