IB BookTrader Bracket Order Adv. Mode

Discussion in 'Order Execution' started by Lorenzo91, Nov 21, 2008.

  1. Hi guys: In Advanced mode Alt left click on Bid or ask size places a bracket order that has a Limit Stop and Target Limit.

    In SIM the same order places a regular Stop underneath.

    What I want is to modify the bracket order to place a regular Stop instead of a Limit Stop because markets are moving so fast it has jumped over my Limit Stops making me panic.

    I would still like to be able to do the same left click alt hotkey.

    Reason I cannot figure it out is because the SIM is different therefore I cannot work it out.
  2. FGBL07


    In BookTrader click "Configure" -> "Hotkeys", select the one you want to change and click "Configure".

    Then choose tab "Customize" and here you can select the order type of your stop order.
  3. sogodo


    by the way, it would be nice to have an ability to program (at least a bit) stoploss and/or target in bracket order(s), using some sort of ATR(X) function.
    I'm sure, it's not too diffficult for IB team just to add this feature (better interface to BookTrader specifically).
    Otherwise, it's kinda troublesome to decompile their java code to add this feature yourself. Plus, your code could break with every next TWS update/release.
  4. dam5h


    I cannot get anything to work with the alt key pressed in sim mode, Is there a limitation on sim mode in this regard? I would like to enter a limit or stop order with a bracket around it.

    I can create stop and limit orders without problem, using a single click. However, the other default functionalities are not working.

    This is with a paper trading account.
  5. Go to configuration/Booktrader.
    Change your order entry to advanced mode. Then the default should be alt left click for one click brackets.

    On the top of the DOM little new buttons should appear. Make sure you are clicked on none. If you find them useful then use them. I find then confusing because in the heat of the moment I forget to switch over.
  6. dam5h


    i have had advance order mode on the whole time, still no dice. the button is on None as you describe. I can click to place limits and stops but not the alt+click for a bracket order. are there any other settings i need to check. i did choose for brackets to be avail in the order types menu under features. thanks for any advice.