Help with IB fx positions

Discussion in 'Retail Brokers' started by 1011101, Nov 25, 2007.

  1. 1011101


    I used to trade some stocks in GBP, but now only hold USD securities. My TWS was showing a negative GBP cash position under the Market Value section. So I rightclicked and selected "Close currency position", it created an order and i executed it. Now I am seeing a GBP.USD position in my portfolio. How do I close out this position so I'm back to all USD?

    Sorry if this is a stupid question or has been covered before. I tried searching here and IB help, but couldn't find an answer.
  2. shanelee


    I have the same problem too. I often trade Forex. And it seems that it only happens after I CLOSED my GBP position. I am wondering how this happened£¿
  3. 1011101


    bump. Can any IB reps on here help with this?
  4. I have been told by IB reps that this is a bug that should be corrected early next year. If you don't want to see the positions, uncheck "Show FX positions in portfolio" under the Portfolio section of the Account window. Keep in mind you will still get the warning message that you are still holding positions when you close TWS.
  5. it happens all of the time
  6. Steve_IB

    Steve_IB Interactive Brokers

    The Market Value section shows your actual cash positions in each currency.

    Our FX model is an instituional style model which accounts for FX on an actual cash basis. It is the correct way to do it and how any hedge fund or bank would do it.

    However, retail clients coming from other FX brokers often have difficulty understanding this concept. So in the portfolio section, we added an option espeically for them "Show FX positions in portfolio for FX traders". This keeps track of currency positions on a "currency pair" basis.

    If you don't trade currencies this way, then untick the box. If you still don't like it, then right click on the line, and select "Adjust Position or Average Size", adjust position to 0, and the line will disapper.