has this ever happened to you?

Discussion in 'Order Execution' started by vongmx, Jan 22, 2009.

  1. vongmx


    I placed 100 shares on the bid about .05 below the current bid on arca and bats and nsdq - and my 100 share order never showed up on my level II . I tried this for nyse and naz stocks and the same result. This never happened to me before I thought it was kind of weird. And the hidden feature was not on. any thoughts?
  2. Who is your broker?
  3. You would need to tell me what is your execution platform?
  4. What stock were you trading?
  5. d08


    Happens to me all the time, especially after modifying an order and hitting transmit, my broker is IB. Seems to happen more often when the SMART routing routs to NYSE (I'm trading NASDAQ only). This is annoying but contacting IB support about such a subtle topic is as useful as kicking yourself in the face.
  6. IBj

    IBj Interactive Brokers

    I would guess you have an incomplete market data subscription set. In order to see the deep book for a US stock you would need to have most (or all) of the following market data subscriptions:

    (1) NYSE or NASDAQ top of book (level 1)
    (2) NYSE Open Book (for NYSE stocks)
    (3) ARCAbook
    (4) NASDAQ Totalview

    click on North America tab
    click on the "Depth of Book detail" sub menu
  7. d08


    You're completely right, I forgot I've canceled my NYSE data subscription. Thanks for the reply.