flash drive problem

Discussion in 'Hardware' started by Wallace, May 17, 2009.

  1. first time install of a new Lexar JD FireFly 4gb flash drive
    old computer with w2k sp4, plugged flash in, driver installs and it's assigned F.
    open explorer, click on F, drag and drop or copy/paste and get this msg:
    'Cannot copy 'file': Cannot find the specified file. Make sure you specify the
    correct path and filename.'

    in Administrative Tools/ComputerManagement/Storage
    /Removable Storage/Physical Locations the usb device has a red disk with
    white X displayed on the listing

    also the drive doesn't appear in the disk management utility

    have you any ideas what might be causing the above and how to fix it ?
  2. Sometimes restarting the computer is necessary.

    Does the flash drive work on another computer?
  3. hi Hook N. Sinker, done the restart, un/reinstall and tested the flash, not in
    another computer but with a small utility program [attached] and it works

    it's a computer problem rather than the flash drive. for all the threads i've
    read after googling several searches there hasn't been a definitive answer
    to the 'cannot find file' problem that many encounter, still checking the 'flash
    disabled' icon

    the few that solve their flash/computer problem seem to do so accidentally.
    the answer/s are going to come from someone who's had the problem and
    solved it or someone who's a technical expert and can identify exactly what
    is going on, where the fault is and provide a probably simple resolution
  4. pspr


    Maybe some of your files are corrupt. Run chkdsk from bootup. I don't know how you do this in w2k but in xp you would do start/run then type chkdsk /r and hit Enter. Then reboot the computer. On startup chkdsk will then check the drive and all files, etc.
  5. hi pspr, no, there's a PCI Simple Communications Controller with an error 28 which is
    no driver for a TelDrive ES56T-PI family V.90 PCI modem which i think is causing the
    problem, tried uninstall and disabling the modem but no luck the Lexar still won't work.
    going to see if i can find a modem driver in win98 otherwise i'll just forget it
  6. maxpi


    This external stuff can be painful... I installed a toaster for backups. Then I made the mistake of opening a word file directly from the toaster and it wiped it out somehow... so now I copy the file back to the desktop and open it from there... I'm happy, the files are happy and the toaster is happy... Windows is here to drive us nuts basically...
  7. problem solved - bought a new computer