Feeding QuoteTracker and Button Trader with TWS

Discussion in 'Trading Software' started by FanOfFridays, Jan 5, 2009.

  1. I have an email in to QT about this and the answer is probably here in the archives, but I'm swamped so for once I'm just posting in case someone has a real quick response for me.

    I'm with IB, and use TWS to feed Button Trader. I'm also using Investor R/T for its Alerts. I found out last night that QuoteTracker has Alerts so I'm checking it out. It's working fine.

    However, I tried to open Button Trader while QT was open (and being fed by TWS) and got the following error message.

    "TWS already has an API client program that is using the ClientId=0 [0]

    Button Trader needs this ClientId.

    Please configure the other API Program with an ID other than 0"

    So does that mean I'm out of luck? Is there another Client ID which QT can use? I'm sure Robert (BT developer) would have put something in the pop-up error message if the BT configuration could be changed in order to accomodate other programs that want to use the Client ID = 0 [0].

    Believe it or not I have been using IB data intraday for a few months (finally punted eSignal, test drove DTN which is not ready for Prime Time, so I'm in between data feeds as it were - my CQG dream did not pan out when I found that I cannot use the CQG data-only feed because it does not come with the API!!). My IB data is feeding Button Trader but it is also feeding my charting program, Amibroker. These two programs can apparently be fed simultaneously by TWS. Is there a limit? What about 3 programs - QT, BT and Amibroker, all fed by TWS??
  2. Holy Jesus!!

    Well, for anyone who doubted Jerry's superhuman responsiveness, believe it. I just got an email from him about 5 minutes after I sent it. He says that I can change the configuration of QT.

    Why BT didn't suggest that I change its configuration, I'm not sure. That seems strange, but anyhow. I guess this thread is redundant.

    Here are his instructions, I'm going to try right now

    Go to OPTIONS/Data Sources menu, QUOTES tab. Select Interactive brokers there. Then set the client ID to any positive integer.


    EDIT: Just in case anyone searches this subject, it worked like a charm.