Exiting TWS crashes PC

Discussion in 'Retail Brokers' started by EMini-Player, Jun 24, 2003.

  1. After the last TWS upgrade, my PC gets a blue screen and automatically restarts when I exit out of TWS. This happens with the Stand-alone and the browser version. I've even tried the previous release 796 and I still get this problem. Anyone else having this issue? Any ideas on what I can do to resolve this problem?


    -FastTrader :cool:
  2. kowboy


    I had three different network cards that caused screen freezes and crashes only when using TWS. NO other programs would crash. Then I called IB tech support and they recommended a 3COM 10/100 PCI TX NIC (3C905b-TX). So for the last three years it has been rock solid and no more problems.

    May not be your problem, but worth a try.
  3. There are problems with Java sockets and certain network cards. Also, there are problems with certain video card drivers and Java.

    First make sure you don't have one of the offending cards. NIC cards are cheap so buying a new one is no big problem.

    Upgrade to Java JRE 1.4.1_03. It contains all the bug fixes and is the version Sun strongly recommends you use.

    Also you may need to upgrade your video card driver to the newest one.

    Upgrade to the current version of DirectX.

    Add this bit to the startup string. Right click on your TWS icon and go to properties. Def published this and comes from IB tech support.


    The above directive as shown in a complete startup string (You may have different directory locations.):

    "C:\Program Files\Java\j2re1.4.1_03\bin\javaw.exe" -Dsun.java2d.noddraw=true -jar D:\Jts\jts.jar D:\Jts
  4. IB is not letting you link in from the outside. They've got some funky frame navigation going on. Screws up my bookmarks.

    Go to the search page and enter:
    Compatible Network Cards
  5. vikana

    vikana Moderator

    The biggest "crash on exit" problem that was present until 1.4.1_03 was related to direct draw on ATI chipsets.

    PuffyGums gave the noDirectDraw setting above. That cured it on my laptop (on all versions of 1.4.1 and 1.4.0)
  6. Thanks PuffyGums. I will try this and post back on whether it worked or not.

    -FastTrader :cool:
  7. Another hint I recall was to reduce or eliminate hardware acceleration on your video card.

    Control Panel>Display Properties>Settings + click on the Advanced button then click on the Troubleshoot tab.
  8. Puffy, adding that noredraw directive seems to have fixed the problem. A BIG Thanks to you my friend. IB support couldn't solve this issue. Good thing we have a community of traders like ET.

    -FastTrader :cool:
    #10     Jun 24, 2003