eSignal efs HTTP Object

Discussion in 'Programming' started by jonkump, May 8, 2019.

  1. jonkump

    jonkump

    Does anyone out there have a working example of an eSignal script reading a file from a http request? I am trying to do something like this

    Code:
    var v = new HTTP("https://mydomain.com/test.txt");
       
       
        if(v.open()) {
          while(!v.eof()) {
             debugPrintln(v.readln());
          }
        }else{
            debugPrintln("open is false")
        } 
    This code always prints "open is false". I also have fiddler open on my desktop and I do not even see any requests firing out to mydomain.com
     
  2. tradingk

    tradingk

    I can only random guess about the issue,

    - is it file permission stopping the code to open it?
    - file is not empty, right?

    As the error is open fail, I believe it stopped at second line and not even touched the rest of code
     
  3. jonkump

    jonkump

    Thanks for the reply. This has been quite frustrating.

    No, it is not a permission issue. The file is viewable in a web browser. I have tried tests on my localhost and a publicly visible domain. v.open() never returns true.

    Another interesting thing to note is that I have tried to set a breakpoint on my server inside of my endpoint. ("http://localhost:55292/chart/getlinescsv?symbol=GOOG")

    When I hit this url in the browser, I hit the breakpoint inside my endpoint, as I would expect, and the file is returned. When I use efs HTTP(), my breakpoint is never hit. Which points more in the direction of the http request is not firing correctly. I also mentioned in my previous post that fiddler does not pick up the request either.

    I also thought maybe it could be windows firewall that was blocking the request from eSignal. I disabled that, but same result.

    I tried to contact eSignal support chat, but they do not offer support on efs scripts. I tried to post on the esignal forum, but I cannot log in. My eSignal credentials do not work, and if you click "sign up", you get "Sorry, registration has been disabled by the administrator."

    This all seems like a total joke to me, how do people work with this software?
     
  4. tradingk

    tradingk

    Another random guess, maybe you should check the HTTP header/response/type of content...etc

    Maybe httpstatus.io or anything similar can help or maybe a hits
     
  5. jonkump

    jonkump

    I don't believe the issue can be related to my http response since my endpoint is never hit.