Do Interactive Brokers forums still exist?

Discussion in 'Interactive Brokers' started by SoyUnPerdedor, Nov 4, 2021.

  1. I have no idea, but my IB workstation no longer works on my computer. It starts to open, the main trading platform screen opens, but then it just locks up and won't let me click anything. The disk drive keep running, and when I cntrl-alt-delete and go to task manager, it says IB is running my disk drive at 50% or so... then after a bit it says it is no longer responding. I tried reinstalling it twice now, on different disk drives. No luck. This is even though nothing has changed on my computer so far as I know.

    Anyways, I am going to call them tomorrow, but I was trying to go to the IB forum to ask if anyone has any idea what the problem can be. But I am having a hard time finding it. Does it still exist?

    Thank you.

    (and if you have any ideas as to what the problem might be thank you even more!)
     
  2. There are two types of IB TWS, one of them auto-updates at the start. Make sure that you have that version. If you want to use the offline one you have to keep an eye on their versions. They might stop working at some point. Offline versions are useful for login automations but they have to be checked regularly.

    Normally a reinstallation of the software fixes the problem.
     
  3. I'm not too familiar with recent versions of TWS. But there used to be cases where insufficient memory was made available and it couldn't run. A setting needed to be changed in the TWS ini file to make it work properly.
     
  4. Exactly, that's what I was referring to.
    Alternatively you may want to verify that your computer is not running out of available RAM memory when you are starting TWS. The reason why I say this is that you mention that your hard disk starts spinning during TWS startup. This could be a sign that you are running out of RAM and that your computer starts using the swap file on the disk as extra memory.
     
  5. Thanks Hobby! So when I contacted IB tech support, he suggested the memory thing, and if that didn't work switching to a different version of IB when I log in. The former did not help. The second works like a charm. So my initial guess was right, the latest version of IB has some issue that is causing my computer to freeze up that no other version has ever done. I hope they get that ironed out soon!

    Thanks again!
     
    HobbyTrading likes this.
  6. Yes it does, but it's mostly about the API: https://groups.io/g/twsapi

    You're welcome.
     
  7. ZBZB

    ZBZB

    Use www.Reddit/r/interactivebrokers has 14.5k members.
     
  8. As the group name suggests, that group is dedicated to API questions. Non-API related questions are often being called out and/or ignored.