Chat Problems

Discussion in 'Feedback' started by Baron, Apr 16, 2002.

  1. Baron

    Baron ET Founder

    If you are having a problem with the chat room, explain it here.
  2. I couldn't get in to the chat today....had an "unknown error while conecting to the DigiChat Server. java.lang.Esception: HttpServlet address not specified....?????
  3. Baron

    Baron ET Founder

    Don, are you still using Netscape 4.7 as your browser? If so, there's not much I can do. Try it with Internet Explorer and let me know if you still have trouble.
  4. DaveN


    I had the same problem....and the same error.
  5. DaveN


    Sorry Baron, I guess I posted at exactly the same time you did.

    I've tried both IE5 and Opera6, same result. Win2K OS.
  6. tntneo

    tntneo Moderator

    could not get in either..
    maybe the problem is with Java 1.4 engine.. Opera, netscape or internet explorer all failed..

    chat with you next time
  7. Baron

    Baron ET Founder

    A few people this past week indicated that they could not log in with JRE 1.4. However, when then reinstalled the JRE 1.3.1, everything worked fine.
  8. Baron

    Baron ET Founder

    Don and DaveN,

    Your errors are because you are behind a firewall. I've been told that the only way I can get you connected is by installing some "HTTP tunneling" software on my end. I am currently getting the scoop on how to do it.
  9. Baron, is there a way we can download the chat log. I'd like to see what went on but couldn't get in either. Thanks

  10. The problem is probably in Java 1.4 rt.jar file. It probably includes the same java classes that the applet was built with but different versions of them. Apparently this is a MAJOR issue with 1.4. Anyway, if you are using IE, you can go to Tools, Internet Options, Advanced Tab. Uncheck the Sun JRE 1.4 for Applets box. Exit all copies of IE and restart IE. It will work because IE will fall back to JRE 1.2 that was included with IE.


    I'm pretty sure that you are misinformed about the HTTP tunnelling. The problem is probably that the chat applet uses some .class that was not included in java 1.3 but is now included in java 1.4 (rt.jar). Somehow, don't ask me how to do it from an applet, the .class that the the chat applet distributes has to be loaded before the same class in the rt.jar file. (The class path has to be modified to include the applet's class before the one in rt.jar). Hope this helps.

    #10     May 16, 2002