Discussion in 'Trading Software' started by stock777, Mar 17, 2009.

  1. I've noticed this a few builds back (ver 890.6 was the last bug free version) and of course the help desk knows nothing about it.

    I thought it was a problem with an existing/old install, as fresh installs seemed not to have this bug, but now I think ITS SOME OTHER BULLSHIT, that should have been fixed.

    I have completely reinstalled TWS and JAVA (so its not that), and I run the standalone, though the bug is also on the webstart version.

    Problem: TWS main screen locks in position, ie , it can be moved at all. Screen updating randomly freezes!! if the mouse is not hovering over the TWS screen area.

    Recreate Problem: Enable Manage Workspaces (Configure/Feature Selector).

    Right click on status bar , click configure, deselect 'show workspace buttons'

    This immediately and reproducibly locks up the window (can't be moved with the mouse)

    I'd like a few of you to try this and see if you get the same issue. Running version 892.9b, but any version after the one I mentioned should have the bug.
  2. Cmon, how about some feedback.

  3. No problem here.
  4. rluser


    i am inclined to agree; i have an open ticket (T541577) which may be related to the symptoms you describe;

    i do not experience what you do, but logging in is flakey (failure before challenge with 'NullPointerException' error) and see periodic 'Out of Heap' messages, particularly after pulling successive underlyings in optiontrader. This latter results in 'freezes' which self recover after half a minute or so (often with thread death according to the log files)

    my wild-assed guess: the client and the server now disagree on the protocol for passing data and fail to trap that condition well
  5. You say no problem. Did you test this exactly as I described on a NEW version.

    I have duplicated this issue on MY main computer (xp) and Windows xp running in a VM , same problem.

    There is very little or nothing that could be unique on my install causing only me this problem.
  6. Your problem sounds unrelated. This seems to be a window control/focus issue. I doubt if it's server related.

    Seems to crop up only if the Workspace Config module is active. Why of 100,000 account I'm the only one reporting this is a great mystery, since this is a 6 week old issue at least.

    Under FRESH install conditions, this is unlikely to be 'user' problem.
  7. The 893 Browser Based version just came out. You might@want to give that a try.
  8. Already tried it. This is almost certainly some bug recently introduced, and it won't be fixed until they reproduce it.

    I wasted a lot of time thinking it was config related, when it appears to be the Workspace module. Might be one of those things no one uses so it doesnt get tested in the field.
  9. More strange shit, this may be the key.

    Im seeing the problem only shows when there is more than ONE workspace in the list. Just the default alone SEEMS ok. Duplicate that and the bug appears.

    Note this has nothing to do with actually 'switching' workspaces.
  10. This is nothing, I've seen persistent quote related bugs that are lasting for years. Stocks tick down when I'm long and crap like that.
    #10     Mar 18, 2009