Booting problem

Discussion in 'Hardware' started by easyrider, Jan 15, 2004.

  1. I reinstalled 2000 on one of my computers and now when it boots up it will do the RAM count up to 512 then start over again and keep doing this until I stop it by hitting escape. Then it will continue the booting process normally. This is a new one on me and I wonder if anybody has come across this problem before.
  2. easyrider,

    Off hand this is hard to tell. Did you touch anything inside your box? Try pushing all memory well into the sockets.

    Often the simplest way is to reinstall. Better still, if you can get hold of a Linux self bootable CD, quickly pop it in and see what it does. You don't have to reinstall yet. If the Linux test would also have trouble with memory, this would confirm what you might fear and suspect: hardware trouble. If Linux goes ok, I would quickly reinstall 2000.

    P.S. see my today's post on Linux in the other hardware thread.

    Good luck with your problem,

  3. The RAM self-test (and count) is done by the BIOS. The OS hasn't even loaded yet (whether from your hard drive or a bootable CD).

    Linux is immaterial - you don't need to try to scrounge a Linux CD - inserting a bootable diskette would be the same test (but you're unlikely to see any difference because what you describe is occuring in the BIOS prior to the actual OS boot cycle).

    Why did you have to reinstall the OS??

    During your reinstall of W2K, did you crack open your box at all? If you did, recheck that all the cards and memory sticks are properly seated.

    If your PC came with diagnostics, try running a memory diag (or if necessary a full system diag) to see if you have a fault. Also, check your PC maker to be sure you have the latest BIOS version loaded flashed into your PC.

    Try activating the BIOS setup program and make sure the stored config has the correct memory size (some PCs will glitch during startup if the BIOS sees a different amount of memory than it has saved in the CMOS config).
  4. Archangel,

    You did not read my post with much care. Did my first line not read:

    "Off hand this is hard to tell. Did you touch anything inside your box? Try pushing all memory well into the sockets."

    Did you suggest anything new? If this does not solve the problem things are not that obvious to a remote observer. Why would easyrider have to reprogram his BIOS given the fact that the only thing easyrider did was to reinstall his OS? That seems to me also rather supurfluous. Even in case that his BIOS would have been out of date, this should not have prevented his system from booting. In such case it would be wiser to first solve the problem and upgrade the BIOS afterwards.

    My suggestion of testing with another bootable OS, ie. Linux on CD, could give a quick indication about the overall state of many hardware components. Your point is well taken though that in case the fault would be in a memory or bios component, the system would not even get out of its bios startup sequel. Of course no OS could boot. Your suggestion of running diagnostics might nor work either if he cannot get out of the BIOS startup.

    If easyrider cannot get his system going after inspecting his hardware for obviuos trouble, I would not say much more. Diagnostics based on a short post without direct observation could be tricky. So I thought it worthwile to add my almost painless suggestion.

  5. Thanks for the input. I went into bios and loaded the default settings and this solved the problem.
  6. Superfulous??

    Interesting what you apparently do and don't consider superfulous.

    Actually I did read your post carefully. Just didn't think your suggestions had much relevence to helping Easyrider resolve the described problem (which perhaps you didn't read carefully given your post).

    He didn't need to reinstall W2K because he'd already said he could escape out of the RAM test and the boot sequence would continue.

    So he clearly didn't need to worry about scurrying around to see if a Linux CD would boot, because he could boot W2K - it was the RAM test during startup that was looping.

    The presumption was that he had NOT cracked open his box just for an OS reinstall, so worrying about the seating of the memory and cards was something suggested he do ONLY IF he had messed around inside.

    And since the problem was most likely in conjunction with his BIOS, the first thing to do was verify the BIOS config and then check the BIOS version (if necessary reflashing the BIOS with the latest version - to make sure there wasn't a CMOS corruption impacting BIOS integrity).

    And hey, what do you know - his resetting the BIOS config DID resolve the problem. So maybe those suggestions weren't so superfulous afterall!!

    As far as diagnostics - since he'd already indicated that he COULD get out of the startup sequnce loop by pressing Escape and the boot to W2K would proceed, if the BIOS settings and BIOS proved to be OK, then running a memory diagnostic was the next logical step since the startup sequence was hanging up on the RAM self-test. The OS loading phase was never an issue in the described problem.

    Anyway, those things seemed a lot more applicable to the stated problem and more likely to yield a resolution than his wasting time running around trying to borrow a Linux CD. But then, that's just me. :)

    Easyrider - glad your problem's resolved.
  7. Ya, anything other than M$ is better to some:D :D :D
  8. Let me continue a bit with this. I built this computer a couple of years ago. Its an 850 Athalon on an Asus A7V motherboard and I have made a thousand different changes on it over the years. For some reason it will not recognize an AGP video card now so I reinstalled the os to see if this would help. It did not. I went into the bios and played with a couple of settings in there that pertain to AGP not really knowing what I was doing so that is probably what caused to ram check to loop. As I said I reset the defaults and that solved the ram check problem but it still will not recognize an AGP video card. Any ideas?
  9. Archangel,

    Let's all be happy his problem is solved:

    To keep some order in what was suggested and what was superfluous:

    (1) I first suggested he look in his box and check the memory fixings. You said the same;

    (2) I suggested eventually reinstalling OS, but first to try testing with booting an OS on a CD. This was not required;

    (3) You suggested checking bios settings - this did the trick for him, congratulations;

    (4) You suggested reinstalling BIOS which was not required.
  10. Hey dotnetter,

    We haven't got a fella Trader.LINUX yet:D :D :D

    #10     Jan 16, 2004