AutoTrader 1.17g is now available, added CME and QuoteTracker data playback

Discussion in 'Data Sets and Feeds' started by autotrader, Jul 23, 2003.

  1. New features in version 1.17g. CME Globex Time and Sales Data playback is now supported. If you want to see exactly how every tick price and size look like accurate down to the second, try playing back CME Time and Sales data. It contains all transactions with price, size and time information, and the data files can be downloaded for free from CME ftp site The CME file contains data for ES and NQ. After downloading the CME zip file, you need to extract the .iom file, and select it when you are prompted to select the CME data file.

    For those who want to playback stock data, I added support for playback of data collected and stored in QuoteTracker. If you are a QuoteTracker user, and you watch stocks data everyday, then you already got your playback data collected. You can select the QuoteTracker option and AutoTrader will playback the data for the symbol you select that is available from your QuoteTracker installation. Make sure you specify the right value for tick size.

    The only trading simulator with the widest choice of playback source. Read the description of each playback source at

  2. Today AutoTrader just stopped working. I didn't make any updates on any of the related software (or any software for that matter).

    When I go to TWS log I see the following message: "JTS-EServerSocket6: [0:9:10:1:0:0:0:ERR] Invalid incomming request type - 0"

    Any ideas?

    TM Trader
  3. I downloaded Autotrader, and it's actually crashed my PC a few times. I was in Simulator mode, and when I switched from YM U3 to NQ U3, and tried to make a trade, it crashed my PC and automatically restarted my PC. Then, I received some device driver error and had to manually turn the PC off and then on to get windows up again. After that, it has crashed twice when I tried closing the program using the "X" in the upper right hand corner.

    I can post or email a log file.

  4. This is the first time I had any problems with AutoTrader and strange problems at that...
  5. This is a known problem in using java with a dual head video card (and probably any fast video chipset). There is a discussion thread about this elsewhere on this board.

    basically if you run into the problem like TTrader did, getting a java virtual machine core dump, you will need to use the jar file version of AutoTrader and create a .bat file containing this line

    start/b javaw -Dsun.java2d.noddraw=true -jar AutoTrader.jar

    save that .bat file in the same location as AutoTrader.jar and run that .bat file to start autotrader.

    I have reports from several users who said the problem went away after doing this.

  6. Thanks! Will try this today. I'll also email you some suggestions/requests for a future release.

  7. Btw, another bug I found today was the Profit is being calculated properly. It was showing -$45,xxx as profit even tho I exited a profitable trade. So, there is some bug there.

  8. that happens if an entry does not have a matching exit, such as you entered a position in AutoTrader, but closed the position in TWS, hence the profit is only showing half the side of the transaction.

    another possible cause is for that symbol that had the wrong value, the multiplier data was not set properly. you can go to the preferences window, and go to each contract, click the details button (you need to be connected to TWS), then click the save button. This will refresh the multuplier value for each contract.

  9. In this particular instance, I was running AutoTrader in Simulation mode, so the position was opened and closed from within AT

    #10     Aug 7, 2003