auto log off in IB

Discussion in 'Retail Brokers' started by z32000, Sep 17, 2007.

  1. z32000


    I always get the auto log off alert in Interactive Brokers.
    I can't seem to figure out where I need to go to disable this.
    Do you all have the same issue?
  2. Vtechno


    Good question. Setting it to 00:00 does not work.
  3. makcim


    There's no way to disable auto logoff.
  4. wiseass


    anyone know wwhats the point of this feature anyway?
  5. z32000


    smart comment...

    so i guess if you set it for the night, then you shouldn't trade at night either....

    waste of a comment.
  6. Yes, every IB user experiences the same issue since this is "a feature" offered in TWS. Many people request to remove "this feature" off but all failed.

    It can't be turned off in any way as far as I know, but you can change the logoff time to bypass it. For example, if you set to logoff at midnight. It will pop up a warning before about 5 mins. You simply change the time to 11:55pm to bypass the logoff.

    If you don't want to do it manually, you need to write a script so it will answer the dialog and change the time for you automatically. Some automation software or scripting language is the way to go.
  7. dst

    dst Interactive Brokers

    Some of our backend software needs to go through required nightly maintenance cycles, which will look like disconnect from TWS side; in addition to that TWS needs to receive some daily control messages which are normally received during login.
    Please note that forcing TWS to stay open overnight (via IBController or any other application) may cause TWS not to function properly.