Acer Aspire has power but otherwise appears dead

Discussion in 'Hardware' started by Earthkanu, Aug 9, 2009.

  1. Earthkanu


    Hi all,

    My Acer Aspire computer does not boot. The hard disk activity LED goes on, and the fans spin up, but otherwise shows no sign of life. I have tried various things, but I have been unsuccessful so far. Any help is greatly appreciated. Thank you in advance!

    Some more detail:

    These are the specifications of my system: Type: Acer Aspire T660-8B7V (desktop computer). CPU: Intel Pentium D 820 (dual-core). RAM: 1 GB DDRII. Motherboard: RC415T-AM. Hard disk: 250 GB SATA. Video: both onboard and ATI Radeon (PCI Express)

    Current symptoms:
    Upon pressing the power button:
    - the CPU fan turns on
    - the red hard disk activity LED goes on and stays on
    For the rest, nothing happens: the power LED does not turn on, the hard disk does not spin up, the screen stays blank, no beeps. On the motherboard there are two other chips that have a cooling fin. One of them, close to the battery, becomes a little warm. I cannot read what kind of chip this is (I suspect the BIOS). The computer does not power off while holding the power button, I need to disconnect the power cable to get it to power off.

    For about one year, this PC has had problems starting up. Sometimes it started up, but got stuck somewhere in the boot cycle before anything showed on the screen. Only the red hard disk activity LED briefly lit up, but then went off again. I had to manually disconnect and reconnect the power cable to get another try. Usually it started successfully without any further problems in two to five tries, but required more tries when it had been powered off for a longer time. I have just returned from a two-week holiday, and now it does not start up at all, no matter how often I try. Current symptoms are described above.

    This is what I tried:
    - I removed all dust using a blower and a brush.
    - I removed all unnecessary hardware one by one. Currently I only have a motherboard, a power supply, a CPU and the memory banks. Made no change.
    - I have tried to reset the BIOS by using the CLR_CMOS jumper, connecting power, wait, disconnect power, put jumper back, connect power again: the only change is that it forgot about its previous power state and I needed to push the power button again for it to start up (so I assume that this procedure went okay).
    - I removed the BIOS battery and power cable. Next morning I tried again: no change. Tried again with the battery back into place: no change.
    - I thought it could be the power supply, so I tried with two different power supplies: no change.
    - There are two slots for memory: I tried all combinations of memory banks and slots using either one or two sticks: no change.
    - I measured the voltages on various locations:
    * 12 V on the four-pin power connector.
    * 5 V and 12 V on the red and yellow power cables that run through the PC.
    * 3.3 V on the SST49LF040B-33-4C-NHE 4 Mbit LPC Flash chip near what I think is the BIOS chip and the SATA ports, it's in the very corner of the board.
    * On the 1394 OHCI PHY Link-Layer Controller: 3.3 V on the VDDP pin, 5.1 V on the DGND pin, 0 V on DVDD pin, 0 V on AGND pin, 0 V on AVDD pin.

    The latter I find strange: I would expect AVDD to be some higher voltage, and I would expect the values of DGND and DVDD to be swapped. I don't know if this is any help, but it is the only lead that I currently have.

    Again, thanks for any help you can give me.

  2. It's a well known problem.

    Your motherboard is probably fried.

    These are pieces of shit and Acer has terrible customer service.

    If it's under warranty, call Acer and yell in three different languages until the agree to send you a new one.